Page tree
Skip to end of metadata
Go to start of metadata

Description:

This property specifies the expected JRE version to compile the Kyvos Formula fields before a dataset build.

Values and behavior:
1.6 - JRE 1.6
1.7 - JRE 1.7
1.8 - JRE 1.8
Kyvos formulas will be compiled using the specified JRE version.

Default value:
1.6

Scope:

  • Cube: If the property is set on a cube, then the value will override the connection level value for that cube’s build job.
  • Dataset: If the property is set on a dataset, then the value will override cube level value for that cube’s dataset build job.

Comes into effect:
The value of the property can be changed at any time and will be respected in the next build.

Dependencies and related properties:
kyvos.build.formulafield.precompile

Recommendation:

Set an appropriate JRE version based on the functions used in the Java functions. Using a Java function not supported by the specified JRE version will cause an error in the dataset and cube build. For example, the function SWITCH is not supported until 1.7.

  • No labels